UpdateSoft

UpdateSoft est un utilitaire permettant de télécharger et installer des mises à jour logicielles.

Utilisé sur un réseau d'entreprise, il permet de centraliser le téléchargement des mises à jour et de gérer leur installation afin d'optimiser la bande passante Internet et s'assurer que les dernières versions soient toujours installées sur vos postes.

UpdateSoft gère les mises à jour logicielles suivantes :

  • Adobe Flash : ActiveX et Plugin (installation uniquement)
  • Firefox (version française) 32 bits et 64 bits
  • Thunderbird (version française) 32 bits et 64 bits
  • VLC (version française) : 32 bits et 64 bits
  • Adobe AIR (installation uniquement)
  • Index Education (Pronote & EDT) : 32 bits et 64 bits
  • Java 8 : 32 bits et 64 bits

Mode d'emploi :

  1. Création d'un script USF de paramétrage (exemple : un script pour le téléchargement ou un script pour l'installation)
  2. Installation du Service UpdateSoft
  3. Utilisation de la ligne de commandes

Vous pouvez choisir de masquer certains onglets de l'application en éditant le fichier UpdateSoft.ini présent dans le dossier de UpdateSoft.exe.


Création de scripts

UpdateSoft ››

Fonctionnement général

  1. Avec un premier script, dédié au Téléchargement, vous allez indiquer à UpdateSoft quels logiciels prendre en charge. Vous programmerez UpdateSoft pour exécuter ce script une fois par jour afin que les dernières mises à jour de ces logiciels soient téléchargées sur votre serveur.
  2. Avec un deuxième script, dédié à l'Installation, vous choisirez les paramètres pour déployer sur tous vos postes clients les logiciels téléchargés avec le premier script. Vous programmerez UpdateSoft pour exécuter ce script par GPO ou en installant le service UpdateSoft sur chacun de vos postes clients.

Note : Eventuellement, pour que votre serveur soit lui aussi mis à jour régulièrement, vous pouvez opter à l'étape 1. pour un script de Téléchargement puis Installation, afin d'installer directement sur le serveur les mises à jour téléchargées.

Mise en œuvre

Dans l'onglet Général, commencez par définir le mode de fonctionnement du script de votre choix :

  • Téléchargement seul : pour téléchargement des composants par le serveur depuis une tâche planifiée. Les installateurs téléchargés seront stockés dans le sous-dossier "Setup" créé au premier lancement de l'application.
  • Installation seule : pour déploiement des composants par le service UpdateSoft ou par GPO
  • Téléchargement puis installation : pour téléchargement & installation des composants par le serveur depuis une tâche planifiée

Selon le mode de fonctionnement sélectionné, les options disponibles dans les autres onglets varieront.

Options générales

Afin de contrôler le fonctionnement d'UpdateSoft durant l'exécution d'un script, vous pouvez choisir d'Ouvrir une fenêtre de journalisation. Si vous ne cochez pas cette case, UpdateSoft exécutera le script en arrière-plan, sans fenêtre visible.

Activez l'option Garder la fenêtre ouverte en cas d'erreur pour que la fenêtre ouverte reste visible jusqu'à ce que vous la fermiez manuellement dans le cas où une opération ne se serait pas déroulée comme attendu. Autrement, la fenêtre se fermera automatiquement à la fin de l'exécution du script, même si le script n'a pas pu réaliser toutes les opérations prévues.

L'option Enregistrer un fichier de journalisation permet de créer, dans le sous-dossier "Log" d'UpdateSoft.exe (dossier créé automatiquement), un fichier portant le nom de la station exécutant le script, et récapitulant le détail des actions effectuées.

Vous retrouverez ainsi dans le sous-dossier "Log" autant de fichiers de journalisation que de stations ayant exécuté vos scripts.

En cochant la case Afficher un message d'information pour l'utilisateur, l'utilisateur de l'ordinateur se verra notifier d'un message comme ci-dessous :

Ce message se fermera automatiquement au bout de quelques secondes si l'utilisateur ne clique pas sur OK.

A la fin des mises à jour, le message suivant apparaîtra quelques secondes :

Aucun message n'apparaîtra si aucune mise à jour n'est nécessaire.

Vous pouvez choisir de Stopper l'exécution du script au-delà d'un certain délai de fonctionnement. Ceci peut-être utile pour forcer l'arrêt de l'exécution du script si l'installation d'une mise à jour logicielle ne se terminait pas dans un délai raisonnable.

Vous pouvez choisir d'Interrompre chaque installation au-delà d'un certain délai d'exécution. Ceci peut-être utile par exemple dans le cas d'un blocage quelconque d'un installateur.

Paramétrez ensuite votre serveur proxy si vous en utilisez un.

Attention : Si vous utilisez le proxy par défaut pour les téléchargements, assurez-vous que celui-ci est bien fonctionnel si vous exécutez le script depuis le service ou le planificateur de tâches. En effet, la configuration proxy étant propre à chaque utilisateur, il peut être préférable de renseigner manuellement le proxy (par exemple : 172.16.0.1:3128) pour s'assurer que le téléchargement des mises à jour ne sera pas bloqué.

Cochez la case Vérifier les mises à jour d'UpdateSoft pour qu'UpdateSoft vérifie la présence d'une nouvelle version en début d'exécution de script de téléchargement, et, le cas échéant, la télécharge puis l'installe.

Systèmes d'exploitation

Cochez le(s) système(s) d'exploitation que vous autorisez à exécuter le script.

Paramétrez enfin le téléchargement / l'installation des différents logiciels ( Adobe Flash , Firefox , Thunderbird , VLC , Adobe AIR , Index Education , Java ) puis enregistrez votre script et testez-le depuis le menu Fichier.

Notes :

  • UpdateSoft installera les mises à jour téléchargées sur toutes les stations depuis lesquelles le script sera interprété : il est donc nécessaire de partager à l'ensemble de vos stations le dossier où se trouve UpdateSoft.exe ainsi que votre script, pour que chacune d'elles puisse procéder aux mises à jour.
  • Pour limiter l'utilisation de l'espace disque, les fichiers de journalisation sont automatiquement tronqués à 2000 lignes.


Adobe Flash

UpdateSoft ›› Création de scripts ››

Activez les mises à jour d'Adobe Flash pour automatiser l'installation de ces mises à jour par UpdateSoft.

En mode téléchargement et installation :

Le téléchargement d'Adobe Flash n'est plus pris en charge, mais la version 31.0.0.108 peut être téléchargée :

  • pour l'Active X, à l'adresse : https://updatesoft.soft-micro.fr/install_flash_player_active_x.exe ,
  • pour le plugin, à l'adresse : https://updatesoft.soft-micro.fr/install_flash_player_plugin.exe .

Ces exécutables doivent être copiés dans le sous-dossier Setup, nommés install_flash_player_active_x.exe et install_flash_player_plugin.exe pour être pris en charge par UpdateSoft pour installation.

En mode installation :

Paramétrez l'action d'UpdateSoft sur le comportement des mises à jour automatisées effectuées par Adobe Flash.

En choisissant de les désactiver, Adobe Flash ne recherchera plus de mise à jour automatiquement.

Sélectionnez Ignorer pour que UpdateSoft ne modifie pas le comportement d'Adobe Flash pour la recherche des mises à jour.

Dans l'onglet Exclusions, saisissez la liste des noms NETBIOS des stations du domaine sur lesquelles vous ne voulez pas qu'UpdateSoft installe les mises à jour Flash.


Firefox

Activez les mises à jour de Firefox pour automatiser le téléchargement et l'installation de ces mises à jour par UpdateSoft.

En mode téléchargement et installation :

Choisissez les modules concernés par le téléchargement ou l'installation (32 bits et/ou 64 bits).

Activez l'option "Télécharger la version ESR" si vous souhaitez que seules les versions Extended Support Release de Firefox soient gérées par UpdateSoft : ces versions présentent moins de mises à jour et présentent une stabilité de fonctionnement accrue.

En mode installation :

Dans l'onglet Général, paramétrez certaines options de Firefox depuis UpdateSoft :

  • Désactiver les mises automatisées par Firefox pour que Firefox ne recherche pas de mises à jour
  • Désactiver les mises à jour des extensions pour que Firefox ne recherche pas les mises à jour des extensions installées
  • Désactiver l'ouverture de l'onglet de Bienvenue qui s'affiche au premier lancement de Firefox après une mise à jour
  • Désactiver la fenêtre de vérification de compatibilité des extensions qui s'affiche au premier lancement de Firefox après une mise à jour

Dans l'onglet Configuration, éditez manuellement les options de Firefox accessibles depuis la page about:config de Firefox.

Note 1 : Un mauvais paramétrage dans l'onglet Configuration peut amener à un fonctionnement incorrect de Firefox. Utilisez cet onglet avec précaution.

Note 2 : UpdateSoft modifie le fichier de configuration de Firefox tenant compte des options saisies, sans effacer les entrées déjà présentes.


Thunderbird

Activez les mises à jour de Thunderbird pour automatiser le téléchargement et l'installation de ces mises à jour par UpdateSoft.

En mode téléchargement et installation :

Choisissez les modules concernés par le téléchargement ou l'installation (32 bits et/ou 64 bits).

En mode installation :

Dans l'onglet Général, paramétrez certaines options de Thunderbird depuis UpdateSoft :

  • Désactiver les mises automatisées par Thunderbird pour que Thunderbird ne recherche pas de mises à jour
  • Désactiver les mises à jour des extensions pour que Thunderbird ne recherche pas les mises à jour des extensions installées

Dans l'onglet Configuration, éditez manuellement les options de Thunderbird accessibles depuis la page Outils > Options > Avancé > Général > Editeur de configuration de Thunderbird.

Note 1: Un mauvais paramétrage dans l'onglet Configuration peut amener à un fonctionnement incorrect de Thunderbird. Utilisez cet onglet avec précaution.

Note 2 : UpdateSoft modifie le fichier de configuration de Thunderbird tenant compte des options saisies, sans effacer les entrées déjà présentes.


VLC

Activez les mises à jour de VLC pour automatiser le téléchargement et l'installation de ces mises à jour par UpdateSoft.

En mode téléchargement et installation :

Choisissez les modules concernés par le téléchargement ou l'installation (32 bits et/ou 64 bits).

En mode installation :

Paramétrez l'action d'UpdateSoft sur le comportement des mises à jour automatisées effectuées par VLC.

En choisissant de les désactiver, VLC ne recherchera plus de mise à jour automatiquement.

Sélectionnez Ignorer pour que UpdateSoft ne modifie pas le comportement de VLC pour la recherche des mises à jour.


Adobe AIR

Activez les mises à jour d'Adobe AIR pour automatiser l'installation de ces mises à jour par UpdateSoft.

En mode téléchargement :

Le téléchargement d'Adobe AIR n'est plus pris en charge, mais la version 32.0.0.1254 peut être téléchargée à l'adresse https://updatesoft.soft-micro.fr/AdobeAIRInstaller.exe .

Cet exécutable doit être copié dans le sous-dossier Setup, nommé AdobeAIRInstaller.exe pour être pris en charge par UpdateSoft pour installation.

En mode installation :

Paramétrez l'action d'UpdateSoft sur le comportement des mises à jour automatisées effectuées par Adobe AIR.

En choisissant de les désactiver, Adobe AIR ne recherchera plus de mise à jour automatiquement.

Sélectionnez Ignorer pour que UpdateSoft ne modifie pas le comportement d'Adobe AIR pour la recherche des mises à jour.


Index Education

Activez les mises à jour de Index Education pour automatiser le téléchargement et l'installation des mises à jour de Pronote & EDT par UpdateSoft.

En mode téléchargement et installation :

Choisissez les modules concernés par le téléchargement ou l'installation (32 bits et/ou 64 bits).

En mode installation :

Paramétrez l'action d'UpdateSoft sur le comportement des mises à jour automatisées effectuées par les produits Index Education.

En désactivant les mises à jour automatisées Index Education, vous laissez UpdateSoft gérer seul les mises à jour Pronote & EDT.

En laissant actives les mises à jour automatisées Index Education, vous permettez au service Index Education d'agir en parallèle d'UpdateSoft pour la gestion des mises à jour.

Définissez les dossiers d'installation de Pronote & EDT (32 bits et 64 bits) : veillez à ce que ces chemins soient accessibles par UpdateSoft durant son exécution (notamment s'il est lancé depuis le planificateur de tâches) : notamment, si Pronote & EDT sont installés en réseau.


Java

Activez les mises à jour de Java pour automatiser le téléchargement et l'installation de ces mises à jour par UpdateSoft.

En mode téléchargement et installation :

Choisissez les modules concernés par le téléchargement ou l'installation (32 bits et/ou 64 bits).

En mode installation :

Paramétrez l'action d'UpdateSoft sur le comportement des mises à jour automatisées effectuées par Java.

En choisissant de les désactiver, Java ne recherchera plus de mise à jour automatiquement.

Sélectionnez Ignorer pour que UpdateSoft ne modifie pas le comportement de Java pour la recherche des mises à jour.

Vous pouvez aussi sélectionner le niveau de sécurité de Java :

Ignorer : aucune modification ne sera effectuée,

Par défaut : rétablit la configuration par défaut de Java,

Très élevé / Élevé / Moyen : selon votre choix.

Si vous choisissez de désinstaller les versions obsolètes, les versions précédemment installées de Java 7 et 8 seront désinstallées sur les systèmes supportant Java 8.

Dans l'onglet Exclusions, saisissez la liste des noms NETBIOS des stations du domaine sur lesquelles vous ne voulez pas qu'UpdateSoft installe les mises à jour Java.

Dans l'onglet Sites, choisissez la façon dont les sites autorisés par Java seront pris en compte :

- Ignorer : cette option indique à UpdateSoft de ne pas modifier la configuration de vos machines

- Par défaut : cette option rétablit le paramétrage Java de gestion des sites par défaut

- Géré : indiquez la liste des sites autorisés par Java

Notes :

  • Si vous précisez un niveau Très élevé / Élevé / Moyen, la barre de positionnement du niveau de sécurité présente dans l'interface de contrôle de Java sera grisée par UpdateSoft.
  • Sur un système 32 bits, seule l'installation de Java 32 bits sera tentée.


Service UpdateSoft

UpdateSoft ››

Depuis l'onglet Général / Service, vous pouvez installer le Service UpdateSoft pour systématiser le lancement d'UpdateSoft au démarrage de l'ordinateur.

Onglet Partage :

Dans le champ Chemin complet vers UpdateSoft.exe, indiquez le dossier dans lequel se situe UpdateSoft.exe. Si le dossier est un partage réseau, vous devez indiquer son chemin UNC complet sous la forme : \\NomOuIpDuServeur\NomDuPartage\Dossier\.

Dans le champ Chemin complet du script à exécuter, indiquez le chemin complet du script UpdateSoft à exécuter. Comme pour le champ précédent, si le script est situé sur un partage réseau, vous devez indiquer son chemin UNC.

Si UpdateSoft.exe est située sur une ressource partagée protégée par mot de passe, indiquez le nom d'utilisateur et le mot de passe nécessaires pour y accéder.

Onglet Contexte :

Spécifiez le compte depuis lequel sera exécuté le Service UpdateSoft : soit le compte système local, soit un compte de l'ordinateur ou du domaine.

Indiquez le Nom d'utilisateur au format Utilisateur@Domaine ou Domaine\Utilisateur puis le mot de passe associé au compte.

Cliquez sur le bouton Tester pour vérifier que les fichiers sont bien accessibles.

Une fois le Service UpdateSoft installé, vous pouvez également choisir une heure où le service UpdateSoft s'exécutera quotidiennement : ceci peut être utile si le démarrage de l'ordinateur s'effectue rarement (cas d'un serveur par exemple) et qu'il est alors nécessaire d'exécuter UpdateSoft plus fréquemment.

Lorsque le Service UpdateSoft a été installé, vous pouvez :

  • Paramétrer une heure d'exécution quotidienne. Ceci n'est nécessaire que si le démarrage de l'ordinateur n'a lieu que rarement (cas d'un serveur par exemple).
  • Le Désinstaller. Ceci peut être également réalisé depuis le panneau de configuration Windows.

A chaque lancement, l'activité du Service UpdateSoft est consignée dans l'observateur d'événements Windows.

L'installation et la désinstallation du service, ainsi la programmation de lancement à heure fixe, peuvent être paramétrées manuellement en ligne de commande .


Déploiement automatisé

UpdateSoft ››

En mettant en partage l'exécutable UpdateSoft.exe, vous pouvez mettre en place différentes méthodes de déploiement automatisé :

  • Déploiement automatisé par GPO (Group Policies Object) :

Pour une exécution automatique d'un script UpdateSoft à chaque lancement des postes de votre domaine contrôlé par un serveur Windows, vous pouvez installer par GPO ( Group Policy Objects ) vos mises à jour logicielles sur l'ensemble de votre domaine avec UpdateSoft.

Note : Assurez-vous d'avoir bien compris le fonctionnement général d'UpdateSoft pour ne dédier à cette GPO qu'un script d'Installation des mises à jour.

    1. Partagez le dossier où se situe UpdateSoft.exe et vos scripts d'installation, nommez le partage UpdateSoft$ et veillez à ce que les Autorisations de partage Modifier et Lecture soient ouvertes à Tout le monde.
    2. Dans la console MMC :
        1. Allez dans Gestion des stratégies de groupe.

        2. Développez l'arborescence, faites un clic droit sur Objets de stratégie et sélectionnez Nouveau pour créer une nouvelle stratégie que vous nommerez UpdateSoft par exemple.
        3. Faites un clic droit sur l'objet UpdateSoft nouvellement créé et sélectionnez Modifier.
        4. Dans la fenêtre qui s'ouvre :

          • Dans le volet de gauche, allez dans Configuration de l'ordinateur > Paramètres Windows > Scripts (démarrage / arrêt).
          • Dans le volet de droite, double-cliquez sur Démarrage, cliquez sur Ajouter et renseignez les champs comme ceci :

Nom du script :

\\[NOM_SERVEUR]\[PARTAGE]\UpdateSoft.exe

Exemple :

\\PDC1\UpdateSoft$\UpdateSoft.exe

Paramètres de scripts :

\\[NOM_SERVEUR]\[PARTAGE]\[SCRIPT_INSTALLATION]

Exemple :

\\PDC1\UpdateSoft$\Install.usf

        5. Après avoir refermé les fenêtres et être revenu sur la Gestion des stratégies de groupe, cliquez sur la GPO UpdateSoft puis faites un glisser/déposer jusqu'au nom de domaine, afin de lier la GPO à l'ensemble de votre domaine.

Ainsi, la GPO UpdateSoft devrait apparaître à la liste des GPO liées à votre domaine :

Notes :

    • Une fois liée au domaine, la GPO s'appliquera à toutes les stations de votre domaine, serveur inclus.
    • Pour désactiver la GPO sans la supprimer, il vous suffit de supprimer la lien que vous avez créé.
    • Pour forcer la prise en compte de votre GPO par le serveur sans tarder, vous pouvez taper gpupdate /force depuis une ligne de commande.
    • Si la GPO ne semble pas fonctionner sur vos postes clients, tentez d'ouvrir depuis l'un d'eux UpdateSoft.exe situé sur le partage. Pour cela tapez , \\[NOMouIPduSERVEUR]\[PARTAGE]\UpdateSoft.exe : si une fenêtre d'avertissement apparaît, alors retentez en modifiant le NOM en l'IP (ou vice-versa).
  • Lancement automatisé par WPKG :

Si WPKG est installé sur votre domaine, vous pouvez créer le package UpdateSoft.xml afin d'exécuter UpdateSoft au démarrage de vos machines clientes, sans installer le service UpdateSoft.

Créez un dossier partagé dédié à UpdateSoft sur votre serveur principal de domaine, dossier accessible en écriture au compte exécutant WPKG.

<?xml version="1.0" encoding="UTF-8"?>

<packages>

<package id="UpdateSoft" name="UpdateSoft" revision="%version%.1" reboot="false" priority="100">

<variable name="version" value="1.0.0.0" />

<variable name="Partage" value="\\SERVEUR\PARTAGE"/> <!-- Indique le dossier partagé d'UpdateSoft.exe -->

<variable name="Script" value="SCRIPT.usf"/> <!-- Indique le nom du fichier de script -->

<install cmd='%COMSPEC% /C start "UpdateSoft" IF EXIST "%Partage%" ("%Partage%\UpdateSoft.exe" "%Partage%\%Script%")' />

</package>

</packages>

Pour indiquer dans un profil WPKG d'installer UpdateSoft, il suffit de l'ajouter via WPKG-Manage , ou d'ajouter manuellement dans le fichier correspondant :

<package package-id="UpdateSoft"/>


Ligne de commandes

UpdateSoft ››

Voici la syntaxe de la ligne de commande de l'application :

UpdateSoft.exe [[/i PARTAGE SCRIPT [UTILISATEUR [MOTDEPASSE]]] [/c SERVICE_UTILISATEUR SERVICE_MOTDEPASSE] [/s [HEURE MINUTE]]] | [/u] | [[FICHIER_1] [FICHIER2] ... ]

Et la syntaxe de la ligne de commande du service :

UpdateSoft_svc.exe /u

/i : Installe le Service UpdateSoft. Peut être combiné avec /s.

  • PARTAGE : Dossier dans lequel se situe UpdateSoft.exe. Si le dossier est un partage réseau, vous devez indiquer son chemin UNC complet sous la forme : \\NomOuIpDuServeur\NomDuPartage\Dossier\.
  • SCRIPT : Chemin complet du script UpdateSoft à exécuter. Comme pour le PARTAGE, si le script est situé sur un partage réseau, vous devez indiquer son chemin UNC.
  • UTILISATEUR : S'il est renseigné, indique le nom d'utilisateur sous lequel le Service UpdateSoft se connectera au PARTAGE.
  • MOTDEPASSE : S'il est renseigné, indique le mot de passe de l'utilisateur.
  • SERVICE_UTILISATEUR : S'il est renseigné, indique le compte sous lequel sera exécuté le Service UpdateSoft ; autrement, le compte Système Local sera utilisé.
  • SERVICE_MOTDEPASSE : S'il est renseigné, indique le mot de passe associé au compte.

/s : Programme / déprogramme le lancement quotidien. Peut être combiné avec /i.

  • HEURE : Indique l'heure de lancement quotidien (entre 0 et 23).
  • MINUTE : Indique la minute de lancement quotidien (entre 0 et 59).
  • Si HEURE MINUTE sont incorrectes ou non renseignées, le lancement quotidien sera déprogrammé.

/u : Désinstalle le Service UpdateSoft. La désinstallation déprogramme le lancement quotidien s'il a été préalablement programmé.

FICHIER_x : Indique le(s) script(s) UpdateSoft à exécuter.

Note : S'il est renseigné, le mot de passe est stocké de façon sécurisée dans le gestionnaire d'informations d'identification Windows .


Historique

  • Version 1.7.9.0 du 07-01-24 :
    • Modification de la méthode de téléchargement des logiciels d' Index Education (compatibilité avec les anciennes versions de Windows)

  • Version 1.7.8.0 du 25-08-23 :
    • Possibilité de définir un temps maximum d'exécution pour chaque processus d'installation

  • Version 1.7.7.0 du 19-05-23 :
    • Prise en charge différenciée de Windows 11
    • Mise à jour de la procédure d'installation de Firefox
    • Mise à jour de la procédure de téléchargement de Java 8

  • Version 1.7.5.0 du 11-11-22 :
    • Mise à jour de la procédure de téléchargement de Java 8

  • Version 1.7.4.0 du 22-07-21 :
    • Mise à jour de la procédure de téléchargement de Java 8

  • Version 1.7.3.0 du 28-01-21 :
    • Fin de prise en charge du téléchargement d' Adobe Flash & Adobe AIR

  • Version 1.7.2.0 du 06-11-20 :
    • Mise à jour de la procédure de téléchargement de Java 8

  • Version 1.7.1.0 du 15-09-20 :
    • Prise en charge des versions 32 bits et 64 bits de Thunderbird

  • Version 1.7.0.1 du 04-02-20 :
    • Amélioration de la compatibilité pour prise en charge des GPO

  • Version 1.7.0.0 du 24-12-19 :
    • Prise en charge des produits Index Education

  • Version 1.6.4.5 du 28-08-19 :
    • Actualisation de la méthode de désactivation des mises à jour de Thunderbird

  • Version 1.6.4.4 du 27-04-19 :
    • Actualisation de la méthode de désactivation des mises à jour de Firefox

  • Version 1.6.4.3 du 17-11-18 :
    • Actualisation de la méthode de désactivation des mises à jour de Firefox
    • Actualisation de la méthode de détection de la version installée de Thunderbird

  • Version 1.6.4.2 du 13-10-18 :
    • Déplacement de Java en fin de procédure de téléchargement & installation

  • Version 1.6.4.1 du 11-08-18 :
    • Correction d'une anomalie mineure qui engendrait une mise à jour de Thunderbird retardée d'un lancement d'UpdateSoft

  • Version 1.6.4.0 du 28-07-18 :
    • Prise en charge des versions 32 bits et 64 bits de Firefox
    • Prise en charge de la syntaxe Utilisateur@Domaine pour l' installation du service
    • Correction d'une anomalie d'affichage sur les bureaux à écrans multiples
    • Correction d'une anomalie qui tentait l'installation de VLC 64 bits sur les systèmes 32 bits

  • Version 1.6.3.0 du 03-06-18 :
    • Prise en charge des versions 32bits et 64bits de VLC

  • Version 1.6.2.0 du 04-05-18 :
    • Possibilité de choisir les systèmes d'exploitation autorisés à exécuter les scripts

  • Version 1.6.1.3 du 03-08-17 :
    • Mise à jour consécutive à une modification de la méthode d'installation de VLC

  • Version 1.6.1.2 du 14-05-17 :
    • Correction d'un bug pouvant indiquer une erreur lors de la vérification de l'existence d'un nouvel installateur pour les composants Mozilla

  • Version 1.6.1.1 du 07-05-17 :
    • Correction d'un bug pouvant indiquer une erreur lors de la vérification de l'existence d'un nouvel installateur pour Adobe Flash

  • Version 1.6.1.0 du 12-10-16 :
    • Amélioration : lorsque la désinstallation de Java 8 ne s'effectuait pas correctement, elle était retentée indéfiniment
    • Amélioration : lorsque le script était interrompu pour durée excessive, aucun message n'était envoyé aux utilisateurs

  • Version 1.6.0.0 du 15-07-16 :
    • Amélioration du service pour une meilleure compatibilité
    • Amélioration de la prise en charge de Firefox et de Thunderbird
    • Amélioration de l'aide pour un déploiement automatisé du service UpdateSoft par WPKG

  • Version 1.5.4.8 du 23-06-16 :
    • Correction d'un bug bloquant l'application lorsque la connexion Internet est inexistante

  • Version 1.5.4.7 du 30-01-16 :
    • Possibilité d'afficher un message d'information à l'utilisateur, lui indiquant que des mises à jour sont en cours
    • Refonte du système de téléchargement pour prendre en charge des liens dont les certificats ne sont pas valides

  • Version 1.5.4.5 du 11-01-16 :
    • Changement des liens de téléchargement pour Firefox , Thunderbird et Adobe Flash pour une meilleure compatibilité

  • Version 1.5.4.4 du 29-12-15 :
    • Les données de configuration de Firefox et Thunderbird n'étaient pas réinitialisées lors du chargement d'un autre script

  • Version 1.5.4.3 du 22-12-15 :
    • Amélioration des opérations de fichiers (suppression, copie, renommage)

  • Version 1.5.4.2 du 13-12-15 :
    • Amélioration du téléchargement d' Adobe Flash

  • Version 1.5.4.1 du 04-12-15 :
    • Correction d'un bug mineur du service

  • Version 1.5.4.0 du 01-12-15 :
    • Amélioration mineure du service

  • Version 1.5.3.5 du 26-11-15 :
    • Suppression de la prise en charge de la version ESR de Thunderbird ( https://www.mozilla.org/en-US/thunderbird/organizations/ ).

  • Version 1.5.3.4 du 19-11-15 :
    • Lancée par le service, l'application ne reste plus ouverte continuellement en cas d'erreur.

  • Version 1.5.3.3 du 17-11-15 :
    • Prise en charge de la nouvelle méthode de téléchargement de Firefox & Thunderbird .
    • Prise en compte des imprécisions de numéros de versions dans Java 8 .

  • Version 1.5.3.2 du 07-11-15 :
    • Amélioration de la méthode de détection de la présence de mise à jour.
    • Ajout d'une animation de temporisation durant les tests pour ne pas figer l'application.

  • Version 1.5.3.1 du 04-11-15 :
    • Mise en compatibilité pour éviter une détection "false positive" d'antivirus.

  • Version 1.5.3.0 du 23-10-15 :
    • Correction d'un bug dans la prise en charge des versions ESR de Firefox & Thunderbird (merci à Olivier Pradier).

  • Version 1.5.2.0 du 22-10-15 :
    • Amélioration du service UpdateSoft (merci à José Company).
    • Prise en charge de Java 8 pour Windows XP.
    • Fin de la prise en charge de Java 7 .
    • Correction d'un bug pour le téléchargement de la version ESR de Thunderbird (merci à Olivier Pradier).

  • Version 1.5.0.3 du 21-10-15 :
    • Mise à jour pour changement de prise en charge de Firefox & Thunderbird .
    • Ajout d'une notification pour l'utilisation du proxy par défaut pour les téléchargements.
    • Correction d'un bug pouvant bloquer les téléchargements sur certains systèmes.

  • Version 1.5.0.1 du 01-10-15 :
    • Amélioration de la tâche de planification quotidienne.
    • Correction d'un bug mineur de désactivation de la tâche UpdateSoft de planification quotidienne.

  • Version 1.5.0.0 du 27-09-15 :
    • Possibilité de déployer le Service UpdateSoft sur l'ordinateur, afin d'exécuter UpdateSoft à chaque démarrage.
    • Possibilité de programmer le lancement d'UpdateSoft à heure fixe quotidienne lorsque le Service UpdateSoft est installé.
    • Correction d'une erreur pouvant bloquer le fonctionnement d'UpdateSoft durant les phases de téléchargement.

  • Version 1.4.0.0 du 26-08-15 :
    • Harmonisation des méthodes de téléchargement Firefox , Thunderbird et VLC
    • Téléchargement d' Adobe Flash et Java optimisé
    • Les installateurs sont désormais stockés dans le sous-dossier "Setup".

  • Version 1.3.7.0 du 08-02-15 :
    • Amélioration de l'ergonomie
    • Correction de fuites mémoire

  • Version 1.3.6.0 du 15-11-14 :
    • Mise à jour des liens de téléchargement d' Adobe Flash

  • Version 1.3.5.0 du 14-11-14 :
    • Mise à jour de la lecture de la version installée des produits Mozilla en version ESR

  • Version 1.3.4.0 du 09-11-14 :
    • Prise en charge des exceptions de sites autorisés sur Java

  • Version 1.3.3.0 du 18-10-14 :
    • Prise en charge de Java 7 et 8

  • Version 1.3.1.0 du 09-08-14 :
    • Prise en charge de Thunderbird

  • Version 1.3.0.0 du 09-08-14 :
    • Retrait de la prise en charge de Symantec Antivirus
    • Interface améliorée

  • Version 1.2.7.0 du 25-04-14 :
    • Possibilité d'exclure certaines stations du domaine de la prise en charge Java ou Flash .

  • Version 1.2.6.0 du 22-03-14 :
    • Possibilité de paramétrer un proxy pour les téléchargements
    • Mise à jour de la méthode de téléchargement de Java 64 bits
    • Prise en charge des nom de fichiers Unicode pour VLC

  • Version 1.2.5.1 du 18-02-14 :
    • Possibilité de gérer les mises à jour ESR de Firefox
    • Correction d'un bug pouvant survenir à l'enregistrement d'un script

  • Version 1.2.5.0 du 15-02-14 :
    • Possibilité de configurer manuellement les options de Firefox

  • Version 1.2.4.0 du 12-02-14 :
    • Prise en charge du paramétrage de la sécurité Java
    • Possibilité de configurer les onglets visibles

  • Version 1.2.2.0 du 25-11-13 :
    • Correction d'un bug pouvant empêcher la lecture de disques ou de fichiers sur VLC

  • Version 1.1.0.0 du 28-10-13 :
    • Prise en charge d' Adobe AIR

  • Version 1.0.10.0 du 01-10-13 :
    • Après mise à jour d'UpdateSoft, les installateurs de Firefox et VLC pouvaient être téléchargés inutilement

  • Version 1.0.9.0 du 30-09-13 :
    • Amélioration de la gestion des fichiers LOG

  • Version 1.0.8.0 du 29-09-13 :
    • Ajout d'une notification dans le journal d'activité en cas d'arrêt pour délai dépassé
    • Prise en charge de Flash ActiveX par Windows 8
    • Normalisation des notifications dans le journal d'activité

  • Version 1.0.7.0 du 28-09-13 :
    • La mise à jour automatisée d'UpdateSoft ne peut désormais se faire que si une seule instance de l'application est active

  • Version 1.0.6.0 du 25-09-13 :
    • Mise en conformité avec VLC 2.1.0

  • Version 1.0.5.0 du 24-09-13 :
    • Amélioration du téléchargement par FTP
    • Correction d'un bug pouvant empêcher l'installation de Firefox
    • Le journal d'activité s'enregistre au format LOG et non plus TXT

  • Version 1.0.4.0 du 17-09-13 :
    • Téléchargement de Firefox par FTP
    • Amélioration de la récupération des fichiers par FTP
    • Défilement automatique en bas de page de la fenêtre du journal d'activité

  • Version 1.0.2.0 du 07-09-13 :
    • Possibilité de mettre à jour UpdateSoft automatiquement lors de l'exécution d'un script de téléchargement

  • Version 1.0.1.0 du 06-09-13 :
    • Première version stable


Liens

Site Internet : https://updatesoft.soft-micro.fr

Auteur : Sébastien Bégouin - contact@soft-micro.fr